准备

Ruby环境:

  • Ruby ,官方推荐安装Ruby+Devkit 2.4.X,保证扩展库的可用性

Python环境(安装python环境是为了提供代码高亮的支持,没需求的可以忽略):

  • Python, 根据自己系统,我选择的是Windows x86-64 executable installer

步骤

  1. 打开下载的Ruby的包,选下路径,一路下一步

  2. 安装Jekyll:

gem install Jekyll --version=[version]

版本号根据需要选择,不加就安装最新的

  1. 安装bundle:
gem install bundle --version=[version]

Jekyll官方文档已经明确说明,版本大于3.8的需要安装bundle

  1. 安装成功,更新gem
gem update

这里是我在安装的时候遇到的,Jekyll的依赖出现各种版本不匹配或者缺失的问题

  1. gem更新完成,可以使用Jekyll的命令,例如:
jekyll serve 

如果还会出现报错,可以使用:

bundle exec jekyll serve  

后续其他命令也会需要加上bundle exec

到这里Jekyll已经可以使用了,如果还需要增加代码高亮的支持,那么:

  1. 安装python,安装包一路下一步,顶多改改安装路径

  2. 安装Pygments:

pip install Pygments

到此安装结束,可以愉快的写博客了。

参考